Система управления задачами IPI.MANAGER™ PRO
Служба поддержки Вопрос-ответ Документация О разработчиках

Технические требования

Сервер

Linux/FreeBSD

Поддерживаются 32 и 64 битные варианты. Используемый дистрибутив не играет никакой роли, главное обеспечить общее требование:

  • Linux Kernel 2.6.x
  • FreeBSD 6.4+, FreeBSD 7.2+, FreeBSD 8.0+

В минимальном варианте никаких внешних библиотек/программ на сервере больше не нужно, однако для “полной” настройки рекомендуются:

  • Apache 2.2.x, mod_fastcgi 2.4.6+ (без этого возможен будет только запуск встроенного веб-сервера)
  • MySQL 5.x / PostgreSQL 8.x (без внешней базы данных возможно использование только встроенной SQLite3, которая обладает существенными ограничениями: например, не поддерживает регистронезависимый поиск)

Аппаратные требования:

способ запуска CPU RAM DiskSpace  
internal webserver + sqlite 500mhz 64mb 100mb min удобно для быстрого тестирования
apache/fastcgi + sqlite 1000mhz 128..160mb 100mb min удобно если <10 сотрудников будет работать
apache/fastcgi + mysql/postgresql 1500mhz 256mb+ 200mb min “настроить и забыть”

Windows

Поддерживаемые ОС: XP, 2003, Vista, 2008. 32 и 64 битные варианты.

В минимальном варианте никаких внешних библиотек/программ на сервере не нужно, однако при этом сервер будет запускаться от имени какого-либо пользователя вручную, без автоматического запуска при загрузке сервера.

Чтобы сервер запускался автоматически, необходимо настроить IPI.Manager в связке с сервером Microsoft IIS (версии 6.0 и 7.0). Однако при этом нужно использовать внешнюю базу данных (mysql 5.x или postgresql 8.x) – со встроенной в IPI.Manager базой SQLite3 такая связка работать будет нестабильно.

Аппаратные требования:

способ запуска CPU RAM DiskSpace  
internal webserver + sqlite 1ghz 256mb 200mb min без автоматического старта сервера при загрузке компьютера, удобно для проверки и тестирования
IIS6/IIS7 + mysql/postgresql 2ghz 512mb (XP/2003), 1GB (Vista/2008) 500mb min полностью автоматический режим

Клиент

Поддерживаемые клиентские браузеры:

Internet Explorer 6: гарантируется работоспособность внешней части (функционал для внешних пользователей). Функционал администрирования / внутренних пользователей может работать нестабильно.

Internet Explorer 7, 8: гарантируется работоспособность (+аккуратный дизайн) внешней и внутренней части, но не функционал администрирования

Mozilla Firefox 3.0, 3.5, 3.6, Opera 10, Apple Safari 3, 4, 5, Google Chrome: 100% работоспособность + быстрая скорость работы

webkit/khtml-совместимые (Konqueror 4, Arora 0.7+): 100% работоспособность.

Объяснение ситуации с Internet Explorer

Ваши клиенты (внешние пользователи) могут использовать любой из современных браузеров, включая Internet Explorer 6. Сотрудники вашей компании (исполнители) могут исопльзовать Internet Explorer 7 (и выше) и любой из других браузеров. Администраторы/менеджеры (для тонких настроек разделов и тп) могут использовать только отличные от IE браузеры для настройки функциональности программы. При этом все функции для исполнителей (управление задачами, создание задач и тп) проверяются нами в IE 7 и 8 версий.

В целом мы принимаем все багрепорты касающиеся негарантированных частей работы, однако такие багрепорты имеют низкий приоритет.

Конфиденциальность Правовые ограничения Лицензия Контактная информация © 1998-2012 Компания IPI